Datasite is seeing poor performance in the America projects and for all users logging in. Users may need to attempt multiple times to access projects and performance will be slow.
Incident Report for Datasite
Resolved
The incident is resolved and performance has been restored.
Posted Dec 12, 2023 - 17:05 CST
Update
Performance is back to normal, but the team is continuing to do work to stabilize the platform long term. We will keep this statuspage up while this work is ongoing.
Posted Dec 12, 2023 - 16:36 CST
Monitoring
Fix was put in place that appears to be improving performance considerably. We are continuing to monitor if any further work is needed.
Posted Dec 12, 2023 - 16:06 CST
Update
Work in continuing on this issue. Some improvements have been seen but performance continues to be poor.
Posted Dec 12, 2023 - 15:38 CST
Identified
The issue is identified and we are currently working to restore performance.
Posted Dec 12, 2023 - 15:20 CST
This incident affected: North America (Datasite Diligence).